StifleR Dashboard access error (Internet Explorer) | 2pint Knowledge Base

StifleR Dashboard access error (Internet Explorer)

Applies to

StifleR Server 1.7

Internet Explorer

Symptoms

When attempting to access the StifleR Dashboard webpage locally on the StifleR IIS Server through http://localhost/StifleRDashboard a Message from webpage dialogue box is displayed showing Failed to communicate with the server. Could not access: http://YourServerURL:9000/api/location

 

Also, when attempting to access the site both locally and remotely through the full URL path http://YourServerURL/StifleRDashboard a 401 Browser Security dialogue is displayed requesting credentials. If you enter your credentials (up to three times as you work through security layers) you can access the page but will need to repeat this again at each page navigation.

Cause

In StifleR 1.7 only members of the StifleR Global Admins Security group are allowed administrative level access to the Dashboards and, if configured, StifleR Global Read members are allowed Read access. This requires authentication and unless your internet security settings allow for automatic logon the errors listed above will be seen regardless of Group Membership.

Solution

This would usually not be seen in a production environment as the necessary settings would be in place to allow automatic credential sharing to access existing resources. Theres more than one way to resolve this error but by way of example, in Internet Explorer, add the StifleR Dashboard website URL into the Intranet Zone which by default is set to allow automatic logon. This can be done locally, directly in the client Browser or through Group Policy.