StifleR Dashboard access error (Google Chrome) | 2pint Knowledge Base

StifleR Dashboard access error (Google Chrome)

Applies to

StifleR Server 1.7

Google Chrome

Symptoms

Note - this is the same error that is covered in the KB article "StifleR Dashboard access error (Internet Explorer)" - The security settings covered in that article will still need to be applied (Chrome also uses the client browser settings) but there is some further configuration required. The full information is included in this article.

When attempting to access the StifleR Dashboard webpage locally on the StifleR IIS Server through http://localhost/StifleRDashboard a Message from webpage dialogue box is displayed showing Failed to communicate with the server. Could not access: http://YourServerURL:9000/api/location

Also, when attempting to access the site both locally and remotely through the full URL path http://YourServerURL/StifleRDashboard a 401 Browser Security dialogue is displayed requesting credentials. This is as far as you will get without further configuration.

Cause

In StifleR 1.7 only members of the StifleR Global Admins Security group are allowed administrative level access to the Dashboards and, if configured, StifleR Global Read members are allowed Read access. This requires authentication and unless your internet security settings allow for automatic logon the errors listed above will be seen regardless of Group Membership.

Solution

This would usually not be seen in a production environment as the necessary settings would be in place to allow automatic credential sharing to access existing resources. Theres more than one way to resolve this error but by way of example, in Internet Explorer, add the StifleR Dashboard website URL into the Intranet Zone which by default is set to allow automatic logon. This can be done locally, directly in the client Browser or through Group Policy.

There is further configuration required in order to access the Website if you are using Google Chrome.

On the IIS server where the StifleR Dashboards have been installed open up Internet Information Services (IIS) Manager and navigate to Sites – Default Web Site – StifleRDashboard and open Authentication (Features View).

Right Click Windows Authentication (which should be enabled) and select Providers.

 

You will be presented with a list of providers which will include “Negotiate”.

Highlight Negotiate and then click the “Remove” button.

After the usual GPUpdate/IIS Reset/Pray to Deity you should now be able to access the StifleR Dashboards without issue.